14 blinks: portfast on Cisco switch helped

Home Forums Botanicalls Community 14 blinks: portfast on Cisco switch helped

This topic contains 0 replies, has 1 voice, and was last updated by  jruys 9 years, 9 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #1388

    jruys
    Participant

    I too was suffering from the dreaded 14 blinks but solved it. Documenting for the forum.

    After some debugging I found the plant keeps the Ethernet down and only activates it when it wants to Tweet.

    This is a good power saving model, but with a (Cisco) ethernet switch the issue is that a port blocks Ethernet traffic for about 10-30 seconds when a device comes online to find out if it is a normal endpoint or a connection to another switch potentially creating a loop. This is normal ethernet switch spanning tree behaviour.

    Problem is that by the time the ethernet port went into forwarding mode and the plant could actually get a DHCP lease, it had given up and was giving me 14 blinks.

    On a Cisco switch you can solve this by adding a command like

    interface FastEthernet0/1

    switchport mode access

    spanning-tree portfast

    which will disable spanning tree and make the plant happy again.

    I would recommend to review the plant’s DHCP behaviour though: when the initial lease request fails, wait 30-60 seconds and try again.

    I agree it’s unlikely a consumer is using an enterprise ethernet switch, but on the other hand no normal consumer has a twittering plant :-)

    Anyhoo – problem solved for me. Off to find a plant to monitor. My wife just decided to move the one I had planned to use as it was nice and close to an Ethernet outlet. Sigh.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.



New kits are here!

Categories

Pothos Plant Tweets

    Flickr Feed

    www.flickr.com
    More photos or video tagged with botanicalls on Flickr

    Meta